CBus to KNX Translator

SECTION 1

SPECIFICATIONS

Part Number
CBUSKNX01 - CBUS to KNX Translator PCB

Function
To convert between CBUS and KNX signals so as to allow both Bus system
devices to be installed in a single system.

Mechanical
PCB Size

108 x 88 mm

Weight

150 grams

Mounting

4 x mounting holes offset 5 mm from each corner

Power Supply
5 to 12 VDC 0.5 Amps regulated

Interfaces




USB (A) - for PC Configuration using free Bus Translator software
KNX - 2 pin removable terminal block for wire termination to KNX bus.
CBUS - 2 pin removable terminal block for wire termination to CBUS bus

Accessories Supplied




USB Cable 1 meter
Mounting screws 4 x M3
Terminal Blocks 2 x 2 way removable
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Electrical Isolation
The CBUS and KNX busses are electrically isolated from each other as well as to
the CBUS to KNX Translator power supply.

CBUS




Number of CBUS Group Addresses: 3000
Unit Address of CBUS Interface: 0 to 255
Applications and Commands Supported
 Lighting ($38)
 Trigger ($CA)
 Zones ($01)
 Security ($D0)
 Clock and Timekeeping ($DF)
 Custom ($02 to $FE)

KNX




Number of KNX group Addresses: 3000
KNX Device Address of KNX Interface: Can be specified
Telegrams Supported
 1 bit On/OFF - EIS 1
 4-bit Relative Dimming EIS 2
 Time EIS 3
 Date EIS 4
 Floating Point - EIS 5
 1 byte (Scaling) - EIS 6

Principle of Operation
The product translates telegrams from CBUS to KNX and vice versa. This is done
by mapping a CBUS telegram to KNX and vice versa.
The Bus Translator software is used to configure the mapping of addresses
between the Bus Systems. The software does not do any programming of CBUS
and KNX; this must be done by the respective CBUS Toolkit and ETS tools.
In the CBUS to KNX mapping page, a CBUS Application and group address is
mapped to a KNX Group address of telegram type On/Off (1-bit), Relative
Dimming (4-bit), Time, Date. Floating Point (2-byte), and Scaling (1-byte)
according to the requirements of the installer. When a CBUS message of the
specified Application and Group address is received by the Translator, it sends a
KNX telegram of the corresponding type to the KNX bus.
In the KNX to CBUS Mapping page, a KNX group address of a specified type
(On/Off, Relative Dimming, Time, Date, Floating, Scaling) is mapped to CBUS
Application and Group address. When a KNX telegram is received, the Translator
will send a CBUS Message of the specified Application and Group Address to
CBUS.
Up to 3000 group addresses can be added to the KNX to CBUS and CBUS to KNX
tables.
The Date and Time can be synchronised between CBUS and KNX
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SECTION 2 INSTALLATION
LED Indicators















D4 “RDY” (Green) - Indicates Power On.
D5 “IN0” (Red) - Blinks when CBUS telegram is received from CBUS.
D6 “OUT0” (Red) - Blinks when CBUS telegram is sent to CBUS. Remains on
when no acknowledgment is received from CBUS after outgoing telegram.
D7 “ERR0” (Red) - Steady when CBUS is not connected or CBUS power
supply is not on, or when the CBUS interface is not initialised or has an
initialisation error. D7 flashes continuously when the EEPROM is blank, ie
unprogrammed. Both D7 and D10 both flash continuously if the U2 EEPROM is
not present.
D8 “IN1” (Red) - Blinks when KNX telegram is received from KNX.
D9 “OUT1” (Red) - Blinks when KNX telegram is sent to KNX. Steady when no
acknowledgment is received from CBUS after outgoing telegram.
D10 “ERR1” (Red) - Steady when KNX is not connected or KNX power supply
is not on, or when the KNX interface is not initialised or has an initialisation
error. Both D7 and D10 both flash continuously if the U2 EEPROM is not
present.
D11 (Green) - blinks when data is received from the USB Port.
D12 (Red) - blinks when data is sent to the USB Port.
LD1 (Red) on CBUS Submodule. On when Burden is enabled
LD2 (Red) on CBUS Submodule. ON Steady when idle, Blinks during CBUS
communication.
LD3 (Green) on CBUS Submodule. OFF when Network Voltage is low or Clock
is not present. ON Steady when Voltage and Clock are present. Flashing when
Bus Voltage is marginal (15-20V)

Connections and Setup
1
2

3

4

Connect the 12V power supply to the Terminal Blocks marked 12V and GND,
taking note of the correct polarity. The module is protected against reverse
connection.
Connect the CBUS Bus Cable to the CBUS terminal blocks, taking note of the
correct polarity. The positive wire of the CBUS signal has a DC voltage of over
20 volts. The module is protected against reverse connection of the CBUS
Bus. A CBUS Power Supply or Dimmer must be present on the CBUS network
in order for product to send and receive CBUS commands
Connect the KNX Bus Cable to the CBUS terminal blocks, taking note of the
correct polarity. The positive wire of the KNX signal has a DC voltage of over
20 volts. The module is protected against reverse connection of the KNX Bus.
A KNX Power Supply must be present on the KNX bus in order for the product
to send and receive KNX commands.
Turn on power to the module. The RDY green led should turn on and the
other LEDS will blink for a few seconds while the Bus Interfaces are being
initialised. After initialisation, only the RDY LED will be steady on provided
both CBUS and KNX Buses are powered up. The module is now ready for
operation if it has been programmed. If it has not been programmed, then
use the Bus Translator Software to program the module.
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SECTION 3 PROGRAMMING
Bus Translator Software
The Bus Translator software tool (for Windows) can be downloaded from
http://www.cytech.biz/bus_translator.html.

USB Driver Installation
Connect the supplied USB cable between the PC and the CBUS to KNX Translator.
If there is an available Internet connection, Windows 7 will silently connect to the
Windows Update website and install any suitable driver it finds for the device. If
the automatic installation takes place there is no need to continue with the
procedure outlined below.

For Windows XP
1

2
3
4

If there is no available Internet connection or Windows XP SP 2 is configured
to ask before connecting to Windows Update, the “Found New Hardware”
screen appears. displayed. Select "No, not this time" from the options
available and then click "Next" to proceed with the installation. Select "Install
from a list or specific location (Advanced)" and then click "Next".
Select "Search for the best driver in these locations" and browse to the folder
Program Files\Cytech\Bus Translator Configurator\USB Drivers\ Click next to
proceed.
If the message dialogue that “the software has not passed Windows Logo
Testing” appears, click on "Continue Anyway" to continue with the
installation.
The Wizard will install the necessary driver files and show when the
installation has been completed. Click Finish to complete the installation.

For Windows 7
1
2
3
4

5
6

If no suitable driver is automatically found then the following procedure
should be followed.
Press the Windows start button to bring up the start menu and select “Control
Panel”.
From the Control Panel window select Hardware and Sound. At the next
screen select Device Manager
In the Device Manager window there will be a device under Other Devices
with a yellow warning symbol to indicate a problem i.e. no driver installed.
The text next to this device will depend on the device attached. In this
example the device was a TTL232R device. Right click on the other device
(TTL232R in this example) to bring up a menu as shown below. From the
displayed menu select “Update Driver Software…”
This then displays the option for an automatic search or a manual search.
Select the second option to browse manually. In the address box put the
exact location where the drivers have been saved to.
After entering the address select “NEXT” to start the installation. When the
installation has finished a completion screen is displayed.

4

CBus to KNX Translator

Using the Bus Translator Software
The Bus Translator opens with a blank screen.

Click File > New and select CBUS-KNX.

The top Menus are described below;
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File Menu

New - Start a new File
Open.. - Open a saved .btxc file
Save - Save a file as .btcx
Save As.. - Save and enter file name for .btcx file

View > I/O Monitor
If I/O monitor is checked then the bottom window will show the messages
between the software and the CBUS to KNX translator. This is useful for testing
and diagnostic purposes.

Transfer






System Information - Read System Information from the module including
Type of Module and firmware version.
Write to EEPROM - Write programmed Configuration to the module.
Read from EEPROM - Read the programmed configuration from the module.
Upgrade Firmware - Upgrade module firmware to a later version. This will be
described later.

Options > Settings
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For Interface Choose USB (NOT RS232 or Ethernet). Click the handle to the right
of Serial Number. You should see a serial number e.g. “A7007is3” in the
dropdown box. If this is blank then the USB Driver may not have not been
installed correctly or the USB cable has not been connected. Click the text “Scan
for USB Devices”, wait a few seconds and look for the dropdown box again. If it is
not found, close and open Bus Translator software again. If the serial number still
is not detected, the driver may be corrupt or an old version of the driver may be
installed. Un-install the driver in Control Menu then reinstall it using the
procedure described above.

Help > About
Displays the version of the software.

Programming
The 3 tabs below the toolbar are Translation Properties, CBUS to KNX and KNX to
CBUS, shown below.

Translation Properties
CBUS Properties





CBUS SIM Version - This is the firmware version of the CBUS Interface (SIM).
This number is seen only after a Read from EEPROM and is a write-only field.
CBUS Unit Address - This shows the CBUS Unit address of the CBUS Interface
(SIM). This number is seen only after a Read from EEPROM and is a
write-only field. The Unit Address can be changed only using the CBUS Toolkit
software.
Dimming Ramp Time - This is the time to ramp from maximum to minimum
brightness and vice versa. In order for dimming commands to be
synchronised between CBUS and KNX, both bus systems should be
programmed with the same value using their respective software tools,
otherwise dimming rates will be different when two lights on both busses are
dimmed or brightened.

KNX Properties




KNX Area - This is the KNX Area number 1 to 15.
KNX Line - This is the KNX Line number 1 to 15.
KNX Device Address - This should be 1 to 255.
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Maximum number of Security Zones - This is the number of security zones
that should be mapped to a consecutive range of KNX Group addresses, e.g.
1/6/1 to 1/6/64 for 64 zones. The security system is assumed to be on the
CBUS Side e.g. Comfort and MinderPro are the best examples of
CBUS-enabled security systems.

CBUS to KNX
The screenshot below is an example of the CBUS to KNX page. Each line shows a
mapping between a received CBUS telegram and a KNX telegram to be sent to
the KNX Bus.
The top menu in the CBUS to KNX screen has the following items;





Add Group Address - Add a CBUS Group address and Application manually to
the table.
Delete Group Address - Delete highlighted line from the table.
Learn - Add a received CBUS message Application ID and Group address to
the table, instead of “Add group address”
Reset to Default - Clear the CBUS to KNX Table. This does not clear the table
in the Bus Translator EEPROM. Write to EEPROM is required.

On the first line, CBUS Lighting Application (application ID 56) with Lighting
Group Address 1 is mapped to KNX group address 0/0/1 as a 1-bit telegram or
On/Off Type. This means that when a CBUS lighting group 1 on or off message is
seen by the CBUS to KNX translator, it will send 1 KNX 1-bit telegram to group
address 0/0/1.
On the second line, CBUS Lighting Group address 1 is mapped to KNX group
address 0/0/2 as Relative Dimming or 4-bit type of telegram. This means that if a
CBUS lighting group address 0/0/1 Ramp to level command is seen by the
module, it will send a 4-bit telegram to KNX group address 0/0/2 to ramp to the
level. CBUS telegrams have ramp time information but not so for KNX telegrams,
This is why the Dimming Ramp Time Parameter in Translation Properties Tab is
needed.

Add a CBUS to KNX Group Address
To add a new CBUS group address to the table, use either “Add Group Address”
or “Learn” buttons. “Add Group Address” will manually add a CBUS Group
Address and Application on a new line.
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Select an application from the list; Zones, Lighting, Trigger, Security,
Timekeeping, Custom..
The “Learn” button will wait for a CBUS message from CBUS to be detected and
will show the received group address and Application ID on a new line.
When the CBUS application and group address have been selected using one of
the above methods, you will need to select a KNX Group address and KNX Type.

Select a KNX Telegram Type from the dropdown list which corresponds to the
type of CBUS and KNX telegram.








On/Off means a 1-bit KNX telegram corresponding to a CBUS On/Off
message.
RelativeDim means a 4-bit KNX telegram which corresponds to a CBUS
Relative Dimming command.
Time means a Time KNX telegram corresponding to a CBUS Time message.
Date means a Date KNX telegram corresponding to a CBUS Date message.
FloatiingPoint means a KNX Floating Point telegram. The incoming CBUS
message has its object value converted to a floating point (“EIS 5”) 2-byte
telegram.
Scaling means a the CBUS object value is sent as a KNX 1-byte (“EIS 6”)
telegram. For example CBUS Lighting application ON value is transmitted to
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the KNX mapped group address as a 1 byte value of 255, and CBUS Off
signal is translated to a 1-byte telegram value of 0
Next enter a KNX Main Group, MidGroup and SubGroup from each pulldown list,
 You will not be allowed to select a KNX group address which already
exists in either the CBUS to KNX or KNX to CBUS Table. However a CBUS
Group address/Application can occur more than once in the CBUS to
KNX or KNX to CBUS tables. This is because a single CBUS group address
may have 1 byte or 1 bit representations while this is not the case for
KNX.
The “Delete Group Address” button will delete a line from the CBUS to KNX table.

KNX to CBUS
The screenshot below shows a typical example of the KNX to CBUS table. Each
line shows a mapping between a received KNX telegram and a KNX telegram to
be sent to CBUS.
The top menu in the KNX to CBUS screen has the following items;





Add Group Address - Add a KNX Group address in 3-level format manually to
the table.
Delete Group Address - Delete highlighted line from the table.
Learn - Add a received KNX Group address to the table, instead of “Add group
address”
Reset to Default - Clear the KNX to CBUS Table. This does not clear the table
in the Bus Translator EEPROM. Write to EEPROM is required.

In the 1st line in the above table, a KNX group address 0/0/4 has been defined as
On/Off or 1-bit type. It is mapped to a CBUS Lighting application Group address
0.
In the 3rd line, a KNX Group address 0/0/17 defined as “Scaling” is mapped to a
CBUS lighting application 1. Scaling type for KNX is a 1 byte value, hence the 1
byte object is mapped as an absolute value in the CBUS lighting application using
the RAMP to level command with NO Delay i.e. instantaneous ramp.
If the KNX Telegram type is defined as Relative Dimming or 4-bit, the relative
value is translated to a CBUS Lighting application Ramp to Level message.
You can use “Add Group Address” or Learn button to add a KNX group address
manually or to add the received group address to the table.
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Select a Telegram Type for KNX. Note that the KNX telegram type which has
been programmed must be known.
Next map the KNX group address to a CBUS Application and Group address.
 You will not be allowed to select a KNX group address which already
exists in either the CBUS to KNX or KNX to CBUS Table. However a CBUS
Group address/Application can occur more than once in the CBUS to
KNX or KNX to CBUS tables. This is because a single CBUS group address
may have 1 byte or 1 bit representations while this is not the case for
KNX.

Write and Read to EEPROM
After the CBUS to KNX tables have been completed, you must do a WRITE to
EEPROM. Before doing so ensure that the Options > Settings USB port has been
set correctly as described in an earlier section.
READ from EEPROM reads the programmed configuration from the CBUS to KNX
translator to the screen.

Dimming Group Addresses
This section explains how to configure dimming between CBUS and KNX group
addresses. It is possible to have a CBUS button dim KNX lights as well as CBUS
lights, and also the converse, i.e. a KNX button dim CBUS and KNX lights.
It is necessary to understand how CBUS and KNX dimming works and the
differences between them

Dimming in CBUS
When a CBUS button programmed for dimming by press and hold is pressed and
held longer than a short press, a RAMP to 100% or 0% with DELAY message is
sent to the dimmer. There is a RAMP time associated with the message from the
switch, which is the time taken to ramp full scale i.e. 0 to 100% or 100% to 0%.
This starts the ramp from the current level. When the button is released, the
button sends an Instantaneous Ramp to Level command to the dimmer group
address. Note that the CBUS switch does NOT send a stop dimming command,
unlike a KNX button.
The button may also be programmed for on and off, in which case it sends an on
or off message to the dimmer.
There is only one group address in CBUS which is associated with the dimming
and on/off actions. CBUS Dimmers and Relays do not send feedback status

Dimming in KNX
When a KNX dimmer button is pressed longer than a short press, a 4 -bit relative
dimming command to 100% or 0% is sent to the dimmer. Unlike CBUS the
telegram from the switch does not contain a ramp time - this has been
programmed in the dimmer using ETS. Hence there is no information in a KNX
telegram regarding the ramp time which the CBUS message can use.
When the KNX button which has been pressed and held is then released, a STOP
dimming telegram is sent to the KNX dimmer. The KNX dimmer may then send a
telegram on a different feedback group address as a 1 byte telegram with the
final value of the dimming level. Note that in KNX it is not the switch but the
dimmer which sends the absolute level. If the device is programmed for ON/OFF
using a short press then the 1-bit telegram will have a different group address
from the dimming group address unlike the case with CBUS. The Dimmer also
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sends the feedback group address on a different 1-bit group address than the
command and the 4-bit dimming group address.

CBUS to KNX Dimming
This section explains how to use a CBUS switch to control a KNX Dimmer.
When the CBUS dimmer button is pressed the CBUS ramp to full scale message is
translated to a 4-bit brighten or dimming to 100% or 0% KNX message. The
CBUS lighting group address should be mapped to a KNX 4-bit group address.
When the button is released, the CBUS button sends an immediate ramp (i.e.
with no ramp time) to level to KNX. This will send a Stop dimming command to
the 4-bit relative dimming group address so the KNX dimmer will stop at the last
level. The dimmer may send a 1 byte feedback value. This can be mapped in the
KNX to CBUS screen to the sending CBUS group address as 1 byte (scaling);
however take note that the absolute value sent by the KNX dimmer may not be
the same value stored at the CBUS switch, due to different dimming rates. This
effect may be seen if the CBUS switch controls both a CBUS Dimmer and a KNX
dimmer. Hence this situation is best avoided.
If the CBUS button is programmed to switch the light on and off the CBUS group
address is mapped to a different KNX 1-bit group address on the dimmer. In this
case a single CBUS group address is mapped to a 1-bit group address, a 4-bit
group address and a 1-byte group address on KNX. This is why duplicate CBUS
group addresses are allowed but not for KNX.
The diagram below shows how a CBUS switch can control a KNX dimmer.
CBUS to KNX Dimming
KNX Dimmer

Cbus
Switch

Cbus
Scene/Slider

KNX Switch

1 bit on/off

1/0/1

1 bit on/off

1/0/1

1 bit status

1/0/2

1 bit status

1/0/2

4-bit dim

1/0/3

4 bit dim

1/0/3

1 byte

1/0/4

1 byte status

1/0/5

KNX to CBUS Dimming
This section explains how to use a KNX switch to control a CBUS Dimmer. When
the KNX dimmer button is pressed the KNX ramp to full scale 4-bit telegram is
translated to a RAMP to 100% or 0% CBUS message. A STOP dimming message
from KNX is translated to STOP dimming command on CBUS when the KNX
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button is released. The KNX lighting 4-bit group address is mapped to a CBUS
Lighting application group address.
The KNX switch does not control the dimming rate, as this is programmed in the
dimmer for KNX. This is where the Dimming Ramp Time in Properties is used.
The command to CBUS will use the Dimming Ramp time so the CBUS dimmer will
ramp with the specified Ramp Time. A KNX switch can dim a KNX dimmer as well
as a CBUS Dimmer if the dim ramp time in CBUS matches the ramp time
programmed in KNX
The CBUS dimmer will not send a feedback status back to KNX.
1-bit group address, a 4-bit group address and a 1-byte group address on KNX
can be mapped to a single CBUS group address. This is why duplicate CBUS
group addresses are allowed but not for KNX.
The diagram below illustrates how a KNX switch can control a CBUS dimmer

KNX to CBUS Dimming

KNX Switch

0/0/1

0/0/2

KNX Scene/slider

1 bit on/off

Cbus
Dimmer

4-bit dim

1 byte

0/0/3
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SECTION 4 FIRMWARE UPGRADING
The firmware of the CBUS to KNX Translator can be upgraded. Firmware
upgrading may be done to introduce new features or fix bugs in exiting firmware.
This can be done using the Bus Translator software.

Firmware Upgrading Procedure
The firmware file has the extension .cbf which is an encoded binary file, e.g.
Cbusknx1_00.cbf. The firmware file can be downloaded from
http://www.cytech.biz/product_details.php?item_id=332
Unzip the cbf file after download.
1
2

Run the Bus Translator software.
Specify the USB connection and serial number in Options > Settings as
described earlier for connection to the module.
3 Select Transfer > Upgrade Firmware.
4 A window to select the file will open. Browse to the folder containing the
cbusknx cbf file and press OK
5 The firmware upgrade will start. A progress window shall appear showing the
progress of the upgrade. This process takes less than 1 minute
 DO NOT interrupt the firmware upgrade, disconnect power or reset the
CBUS to KNX module during the procedure. If there is any error,
immediately attempt the upgrade procedure again as described above.
After the upgrade is completed the module will reset itself and the
indicator LEDs will behave as described earlier in this document.
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Document Revision History





1 November 2011 - Initial Release 1.01
16 December 2011 - Updated 1.02 for firmware 1.004, added diagrams
12 Dec 2103 - Corrected error in range for KNXArea and Line
7 April 2016 - Added designation to LEDs D7, D8 etc. Described led behaviour for
errors

Important Note
The printed manual may not always be the most current version. Please check
and download the latest version from http://www.cytech.biz/manuals.html
This manual is in A4 format. To print this manual as an A5 Booklet, on HP PCL
printers select Page Scaling = Fit to Printable Area. Select Properties > Finishing
Tab, Document Options = Print on Both Sides, Booklet Layout = Left Side
Binding. Other printers may have different settings to achieve the same result.
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